What are the device requirements for the Digidentity app?

To download and use the Digidentity application please check these requirements:

  • iOS devices (iPhone, iPad, iPod touch) using iOS version 8 or later.
  • Android devices with a camera, using Android version 4.0.3 or later.
  • Windows mobile devices with a camera, using Windows 10, Windows Phone 8.1.

 

Have more questions? Submit a request